Check out the new version of the Miners Need Cool Shoes editor!

You need Flash to use the armory :( If you're a Iphone user perhaps you would like to check out the iphone app...

Get Adobe Flash player